Unity application not working for zSpace

0 votes
asked Oct 26, 2015 by andrewjsolis13@gmail.com (168 points)
Hey Guys,

    We are trying to run a Unity demo on the zSpace model 100 and, whenever we try and run the demo through Unity it gives us an error:

    Failed to load 'Assets'Plugins'zSpaceUnity.dll', expected 64-bit architecture. You must recompile your plugin for 64 bit architecture.

    Is this talking about the ZSCore 3.0.1 Unity Plugin? We have tried redownloading the SDK as well as the plugin but it is still giving us this error. Currently we are trying to run this on Unity5 64-bit. I know this is not officially supported, but we were trying to see if we can still get it somewhat to work for our demo, since a lot of our applications and demos are done in Unity 64-bit. If there is anything we missed or another step we need to take please let us know, and any help will be greatly appreciated.

 

Thanks

Andrew Solis
commented Nov 3, 2015 by dtwilleagerinfinitez-com (275 points)
There will be another Unity plugin release, with many new debugging features, as well as a new zView plugin, probably early next quarter.    We will also be looking into new ways to keep developers informed - like release announcements.

1 Answer

+3 votes
answered Oct 27, 2015 by dtwilleagerinfinitez-com (275 points)
selected Oct 27, 2015 by andrewjsolis13@gmail.com
 
Best answer
We currently don't build a 64bit dll for the 3.0.1 plugin.  We are releasing a new plugin within the next week or so that does support both 32 and 64 bit Unity 4 and 5 builds.  The only solution until then is to use the 32 bit Unity 5 editor.
commented Nov 3, 2015 by Jesse_Thompson (192 points)
It looks like the new SDK is out. (Hooray!) I'm assuming a zView update is a few weeks away yet?  Getting announcements (even on twitter) for releases would be great.
...