Screen is black in Unity preview window and freezes zSpace

0 votes
asked Dec 5, 2017 by gpiffaretti (25 points)
After using stereo view, the screen goes black and the zSpace freezes.

This happens with my local build and with the preview window inside Unity. In the preview window, I never get to see the preview, it's just a black render.

Any ideas about why this might be happening?
commented Dec 5, 2017 by AlexShorey (265 points)
Hi there,

I haven't experienced or heard of this issue, but I'd like to help.
From the sound of your prior question, it was was working at an earlier point, is that correct?
Have any conditions been narrowed down that may be related?
My first thought might be to cut out any extra cameras from the scene to see if zcore is getting confused about which one it should be referencing.
If you can share a simple scene that produces the problem, I'll definitely take a look at it.

Alex S.
commented Dec 6, 2017 by gpiffaretti (25 points)
It looks like is something related to the hardware or drivers. It also happens when I use the control panel, in either the head tracking or the head tracking test.
I updated the system software to 5.2.2 but it's still happening.

The weird thing is that this happens AFTER I use the app. Either preview window, head tracking test, Leopoly, all of these work, but when I close them. BAM! Screen goes black and I have to reset because it looks like there's no way of getting out of there.
commented Dec 6, 2017 by gpiffaretti (25 points)
I don't know if it worked before :( I was working in mono rendering mode, in the scene view, but now I need to start testing and working in stereo.
commented Dec 6, 2017 by AlexShorey (265 points)
Ouch, well that's no good. I'm following up with some associates that may know more. In the mean time, could you grab us the firmware versions listed in the zSpace Control Panel's System Information menu, as well as the driver listed for the Display Adapter in Window's Device Manager?
commented Dec 6, 2017 by AlexShorey (265 points)
Possibly good news! I just heard back, and this is a known issue for Windows 10 anniversary edition (1607) This can potentially be solved by updating to Win 10 crestor (1703) or creator update (1709). If these don't work, or you need to stay on anniversary edition, we can look into hooking you up with a different display driver.
commented Dec 6, 2017 by gpiffaretti (25 points)
thanks Alex! I'm not with the zSpace right now but I'll try that tomorrow and let you know.
commented Dec 6, 2017 by gpiffaretti (25 points)
it would be better if I could get a different display driver though. I can post my zSpace specs tomorrow and we can take a look
commented Dec 6, 2017 by AlexShorey (265 points)
edited Dec 6, 2017 by AlexShorey
If a driver is best for your situation, try whichever one matches your system on this support page.

https://support.zspace.com/hc/en-us/articles/206458535

Edit: I'm told you should try the driver listed for the AIO model if you have a 300 model.
commented Dec 7, 2017 by gpiffaretti (25 points)
IT WORKED!!!

Downloaded the driver for the AIO model for my 300 model.

Thanks a lot! This issue was really annoying :D
You can post that as an answer and I'll mark it as correct

1 Answer

0 votes
answered Dec 7, 2017 by AlexShorey (265 points)
selected Dec 7, 2017 by gpiffaretti
 
Best answer

As detailed in the comment thread, this turned out to be a video driver issue.

Updating Windows is one possible solution.

Grabbing an updated graphics card driver is another possible solution.

Getting a latest driver from AMD can potentially work, but there are also confirmed working drivers that can be located at this link.
https://support.zspace.com/hc/en-us/articles/206458535

If you're dealing with a 300 model zSpace and going the driver route, we recommend grabbing the driver specified for the AIO model zSpace on that page.

...