Problem with Unity zCore / open preview window fails - createSwapChain() : Failed to IDXGISwapChain1

0 votes
asked Jan 8, 2018 by gdl (20 points)

Hi, I get the following message when trying to open the preview window in Unity (from the menu and from the inspector) :

[zCoreUnity] StereoWindowD3D11::createSwapChain() : Failed to IDXGISwapChain1.

I tried with Unity version 5.6 and the latest 2017.3. same behavior.  

Plugin version is 5.0.0 , runtime version 4.0.0

Tried from a blank project using zCore import, and also tried from an existing 2017 working template project from this forum.

Any idea ? 


commented Jan 8, 2018 by AlexShorey (267 points)

We're not sure what's going on here at first glance. Could you help us with some extra information?
What version of Windows and latest Windows update is the system on?
GPU model and driver version?
commented Jan 9, 2018 by gdl (20 points)
Hi, I'm on windows 7 enterprise, service pack 1, 64 bit
Lenovo w530
gpu is a NVIDIA Quadro K200M, driver 311.35

I've been running other stereo apps without problems.
The existing zspace demos run well.

1 Answer

0 votes
answered Jan 9, 2018 by AlexShorey (267 points)
Thank you for the additional information. Unfortunately, the preview window is built around D3D11.1 which requires at least Windows 8.1.
commented Jan 31, 2018 by gdl (20 points)
edited Jan 31, 2018 by gdl
Thank you for your reply . Does that apply to the build too ? when I try the build (still on Win7) , it doesn't have stereo enabled although all the right options are checked (2017.3.0f3, all  - vrmode stereo etc) .  
Would that help to develop using the old version of unity/zcore plugin (the 4.0)  to maintain the compatibility ? would the result work  on both win 7 and win 10 ?  my applications would have to run on z200 and the latest z300 systems.